28 octubre 2011

 

Couldn't delete previous backup ids

Hemos ido a realizar una copia de seguridad de un curso de nuestra plataforma Moodle cuando hemos obtenido un error cuyo aviso da título a esta entrada:

"Couldn't delete previous backup ids"

Este error se da típicamente debido a que la base de datos MySQL se ha corrompido, normalmente por algún fallo en el disco duro como por ejemplo cuando el disco duro está lleno.

Aparte de abordar los posibles orígenes del error, este problema puede ser reparado utilizando el comando mysqlcheck siguiendo la siguiente sintaxis:

#mysqlcheck -u usuariomoodle -p --auto-repair moodle

En este comando se entiende que usuariomoodle es un usuario con los suficientes privilegios para administrar la base de datos que en este caso se supone se llama moodle.

Comments: Publicar un comentario

Links to this post:

Crear un enlace



<< Home

This page is powered by Blogger. Isn't yours?